Wednesday, August 21, 2013

QTP Object Recognition problem with .Net 4.0

QTP Object Recognition problem with .Net 4.0


We had a serious problem for past some days in .Net object recognition using QTP 11, application which was recognized by QTP 11 was started to get unrecognized. We uninstalled our application under test (AUT) and installed it once again, but the problem still persist. We did the same for QTP 11 also.

We then found that, recently our application migrated to support .Net 4.0, hence during application installation, the 4.0 framework will get updated automatically, and it turns out to be the culprit.

Because of the .Net 4.0 framework update, the QTP which suppose to recognize .Net object is not recognizing any of them.

I then found a very interesting article written by Joe Colantonio, but the problem to fix was not fruitful. In the article Joe mentioned to install the following DLL files

Mercury.QTP.Agent.dll
Mercury.QTP.WpfAgent.dll
I tried to install the same, but the problem is, both the DLL files didn’t install in your assembly folder under c:\windows\assembly, rather it gets installed under C:\Windows\Microsoft.NET\assembly\GAC_32 and C:\Windows\Microsoft.NET\assembly\GAC_MSIL respectively.

The problem with QTP 11 is, QTP will always point to .Net Assembly under c:\windows\assembly folder, whereas our DLL files are being registered under different location of GAC, hence the fix which Joe Colantonio mentioned is not working and the same is the problem with the fix which HP has provided.

Share your thoughts !!!

Please leave your comments and rate the post !!!

No comments: